[Home] [Downloads] [Search] [Help/forum]


Register forum user name Search FAQ

Gammon Forum

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Text Right-To-Left Input Bug

Text Right-To-Left Input Bug

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Elraver   (3 posts)  [Biography] bio
Date Tue 13 Mar 2007 10:50 PM (UTC)
Message
So, pretty much every time I use the the Ctrl+Shift+F to 'Search Again', this happens. The Up-Down Command History buttons on the Input Bar move to the right side and text starts to enter on the right side... but not /just/ that.

If I start to scroll through command history using the buttoms, randomly it crashes. If I switch World windows using Ctrl+Tab, only the one World input bar is affected, and eventually upon switching back to the affected one, it switches back to normal. Upon experimentation, almost every command that uses Ctrl+Shift+(anything) causes this bug to occur.

When entering text, it starts on the right /side/ of the bar, but the text still enters from the left to right, then after hitting space to move to the next word, the cursor goes all the way to the left of the text, still on the right side of the bar, with one space obviously cause you just hit space. However, when you type again, it moves the cursor back to the very very right and enters text left to right again. The only exception, is when you enter symbols like # instead of text or numbers. Then it inputs it on the very left, as it did with the spaces. But then, corrects itself when you type a normal letter or number again.

Here is a screenshot:

http://www.elraver.com/bug20070313.jpg

Those words were typed in the order of First, Second, Third, and #####, without a space after the #####. The screenshot couldn't seem to capture the cursor, but it is currently resting and blinking on the left side of the #####.

elraver
[Go to top] top

Posted by Nick Gammon   Australia  (22,966 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Wed 14 Mar 2007 03:56 AM (UTC)
Message
I can't reproduce that, and have never heard of it. I suspect you have configured Windows to use Ctrl+Shift+F to change your input mode (eg. if you have installed a right-to-left font), and this is overriding MUSHclient's accelerator key, and confusing it.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Elraver   (3 posts)  [Biography] bio
Date Reply #2 on Wed 14 Mar 2007 06:39 AM (UTC)
Message
I found someone else, albeit from 2005, that has had this or at the least a problem that sounds similar on this Forum.
From page three of this forum section. Posting it here:

---

Posted by: Poromenos - Greece (1,011 posts) [Biography] bio
Date: Tue 08 Nov 2005 11:54 AM (UTC)
Message: If you press ctrl+shift+f4 and cancel the prompt to close, the input box gets a vertical scrollbar on the left and the text becomes right-justified and won't go back. I think that works for other combinations as well, like Ctrl+Shift+1, etc. What is it?

---

Also, it happens with any key combination that is Ctrl+Shift+Anything. And annoyingly, it doesn't happen every time, sometimes it doesn't happen until I press the key combination a second, third, or even fourth time. I tried removing all unneeded programs from memory residency and have no other keyboard shortcuts active. All programs were closed except for Mushclient, even the Volume Panel icon was shut down from the taskbar tray. It also happens through different versions. I installed an older one and the problem persisted. I'm back up to the most recent now.

I'm going to try and destroy anything Mushclient related from the registry, and reinstall. See if that helps.

elraver
[Go to top] top

Posted by Nick Gammon   Australia  (22,966 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Wed 14 Mar 2007 07:36 AM (UTC)
Message
You are referring to post:

http://www.gammon.com.au/forum/bbshowpost.php?id=6063

I'm not sure what to suggest here. There is no code in MUSHclient to do right-to-left text, so there must be some external influence at work.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Elraver   (3 posts)  [Biography] bio
Date Reply #4 on Wed 14 Mar 2007 07:51 AM (UTC)
Message
Sir! I must apologize. :) I decided to check out this 'bug' with other programs. In just regular typing like in notepad or textpad, it makes no difference. For some reason, in SimpleMU it doesn't cause any problems either. In mIRC however, I did a Ctrl+Shift+F which has no effect in the program, but the problem with the text input bar occurred once more! I'll move my inquiries to Windows support forums rather than bother ya'll further. :)

elraver
[Go to top] top

Posted by Beale   (35 posts)  [Biography] bio
Date Reply #5 on Tue 08 May 2007 08:36 PM (UTC)
Message
I've found that pressing Control and the right shift key produces the effect described, while pressing Control and left shift reverses it.

Very odd.
[Go to top] top

Posted by Isthiriel   (113 posts)  [Biography] bio
Date Reply #6 on Fri 11 May 2007 09:19 PM (UTC)
Message
The standard text controls under Windows XP (and presumably Vista) are set up to use Ctrl+LShift/Ctrl+RShift to signal whether you want to enter text LtR or RtL.

I believe it is only enabled if you have Supplemental Language Support (complex script and right-to-left languages) installed, and once activated can't be disabled without uninstalling same.

Personally, it would be nice to be able to turn it on/off on a language-specific basis with the Language Bar but Microsoft in their infinite wisdom decided this was not to be so. :(
[Go to top] top

Posted by Nick Gammon   Australia  (22,966 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Fri 11 May 2007 10:12 PM (UTC)
Message
Does that mean you can make English read right-to-left, although not many English speakers write text that way?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


26,848 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at HostDash]